Back to overview
Degraded

Degraded dashboard performance

Jun 30 at 05:23pm EDT
Affected services
tryprofound.com

Resolved
Jun 30 at 05:31pm EDT

The issues have been resolved. We are continuing to monitor performance.

Created
Jun 30 at 05:23pm EDT

The dashboard's performance has degraded due to high latency experienced by our authentication provider, Clerk. We are monitoring the situation.